It’s not a bug – it’s an undocumented feature.
I'm looking at the Watopia Sprint Reverse segment leaderboard.

segments.php?id=7

Top time shows Power of 399 W.
Second place shows 921 W.
Third place shows 1068 W.
Fourth place shows 1323 W.

Similar results in the other sprint segments that I've looked at.

How is the power for the sprint segments calculated?
Bhaltair Gruamach wrote:
Thu Feb 28, 2019 4:07 am
I'm looking at the Watopia Sprint Reverse segment leaderboard.

segments.php?id=7

Top time shows Power of 399 W.
Second place shows 921 W.
Third place shows 1068 W.
Fourth place shows 1323 W.

Similar results in the other sprint segments that I've looked at.

How is the power for the sprint segments calculated?
Information is sent by Zwift and is not always accurate.
i road alpe de zwift yesterday and ur shown power values are way off what i had to push up that hill

my trainingspeaks shows me 266 watt / 3.2watt/ kg for the KOM

in zpoints ur showing 186 watt and 2.3 watt/ kg

so something must be really wrong here i never went below 250 the whole climb.

as zpoints are relevant in ur analysis it would be nice to get a correct value their.
actully the whole ride incl flat section to the climb was >255watt.
RRadler wrote:
Sun Mar 03, 2019 4:18 pm
i road alpe de zwift yesterday and ur shown power values are way off what i had to push up that hill

my trainingspeaks shows me 266 watt / 3.2watt/ kg for the KOM

in zpoints ur showing 186 watt and 2.3 watt/ kg

so something must be really wrong here i never went below 250 the whole climb.

as zpoints are relevant in ur analysis it would be nice to get a correct value their.
actully the whole ride incl flat section to the climb was >255watt.
Unfortunately there is a known bug on that segment; Zwift sends bad data to ZP.
lol :mrgreen:
I have observed the same for my races up the Alpe, on Saturday I did a 41:52 for 263 watts according to this, but my Garmin recorded an average of 270 watts.

I have seen that all of the power-duration statistics for my rides are under-reported here and have done a little black-box testing on it, by comparing the power-duration curve (in Golden Cheetah) using the fit file from:

1) My Garmin
2) The local fit file recorded by the Zwift client
3) The fit file downloaded from the Zwift website
4) The fit file from Zwift Power

My observations on this are:
1. The power-duration curve for a given race matches for cases 1-3, but case 4 is always low
2. The power-duration curve reported in Zwift Power matches the fit file available for download from Zwift Power

This suggests to me that the process that extracts the "race" portion of the Zwift session is at fault and it is applying some form of filtering, but it is amazing that such filtering can affect a climb as long as the Alpe - as the OP states, it does affect ZPoints etc, so it would be nice for this to be resolved.